Ask Your Question
1

gettextsetup warnings

asked 2017-09-13 10:35:51 -0600

SirDice gravatar image

After updating puppet from 4.10.5 to 4.10.6, and recently 4.10.7 my logs are swamped with warning messages about GettextSetup.

For example:

Warning: GettextSetup is not available, skipping GettextSetup initialization for mysqlserver.
Warning: GettextSetup is not available, skipping GettextSetup initialization for pkgclean.
Warning: GettextSetup is not available, skipping GettextSetup initialization for openntpd.
Warning: GettextSetup is not available, skipping GettextSetup initialization for apache22.
Warning: GettextSetup is not available, skipping GettextSetup initialization for sudo.
Warning: GettextSetup is not available, skipping GettextSetup initialization for sshd.
Warning: GettextSetup is not available, skipping GettextSetup initialization for monit.
Warning: GettextSetup is not available, skipping GettextSetup initialization for smartmon.
Warning: GettextSetup is not available, skipping GettextSetup initialization for motd.
Warning: GettextSetup is not available, skipping GettextSetup initialization for accounts.
This goes on and on. For every module I get multiple warnings and for every agent run on every node.

My question is two-fold: 1. How do I fix this? What needs to be configured/upgraded/installed/whatever to satisfy Puppet? 2. Failing to fix this, how do I disable this warning? My logs are now utterly useless because the warnings swamp everything.

Currently running Puppet 4.10.7 on FreeBSD 10.3. The warning also shows up with Puppetserver 2.7.2. Installing the gettext and gettext-setup gem doesn't help.

edit retag flag offensive close merge delete

Comments

Same issue here.. It's almost impossible to find anything about it. It seems to only happen on FreeBSD for what I can find which might explain why there's so little to find about it. Still, pretty annoying.

Xzenor gravatar imageXzenor ( 2017-09-21 05:45:44 -0600 )edit

I'm seeing it on our Puppet server (2.6.0) running on Ubuntu 14.04 LTS

cpitkin gravatar imagecpitkin ( 2017-09-29 08:49:02 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2017-10-02 17:06:16 -0600

buzzdeee gravatar image

updated 2017-10-03 16:55:57 -0600

I see the very same behaviour with puppet 4.10.7 on OpenBSD -current amd64:

However, after some more digging, I found that the OpenBSD puppet package maintainer (which accidently happens to be myself) missed the new? --localedir parameter, which pointed to /opt/... per default. /opt is a no-go under OpenBSD. So now telling the install.rb to install to a proper location: /usr/local/lib/ruby/site_ruby/2.3/puppet/locales then only the main ruby.rb file had to be patched to actually not look into ../locales but into ./puppet/locales to actually find it.

after release freeze it should be fixed for puppet-4.10.7p0 package.

edit flag offensive delete link more

Comments

I was thinking it would be something like this. I just don't have the issue on any of my Linux Puppet installations, I'm really only seeing it on FreeBSD. So it already started to look like this issue was specific to *BSD. Thanks for the pointer, it looks like I may need to nudge the port maintainer

SirDice gravatar imageSirDice ( 2017-10-04 08:27:14 -0600 )edit
0

answered 2017-10-03 08:10:32 -0600

rjc gravatar image

Same here - OpenBSD -current - puppet master won't shut up!

...
Oct  3 00:00:00 machine puppet-master[12345]: GettextSetup is not available, skipping GettextSetup initialization for [module name]
...

Logs are useless - due to the flood of the above messages, they are rotated every couple of hours.

edit flag offensive delete link more

Comments

For OpenBSD have a look at the answer provided by buzzdeee. It will probably be fixed for you with the next package updates. And it looks like I need to nudge the FreeBSD port maintainer to follow suit.

SirDice gravatar imageSirDice ( 2017-10-04 08:38:25 -0600 )edit
0

answered 2017-10-03 08:21:28 -0600

This is a known issue. Install the gettext gem on the puppetserver.

Works on Ubuntu 14.04 but should be similar on BSD systems. /opt/puppetlabs/bin/puppetserver gem install gettext

edit flag offensive delete link more

Comments

Already installed. I installed both rubygem-gettext and rubygem-gettext-setup. I also installed them in puppetserver; the error however remains.

SirDice gravatar imageSirDice ( 2017-10-04 08:24:48 -0600 )edit
0

answered 2017-10-17 01:00:30 -0600

I had the same issue on my Linux installation. I could fix it by running this:

$ sudo /opt/puppetlabs/bin/puppetserver gem install gettext-setup

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2017-09-13 10:35:51 -0600

Seen: 625 times

Last updated: Oct 03