Ask Your Question
1

apache mod fastcgi

asked 2017-09-25 09:38:57 -0500

Sudodevnull gravatar image

updated 2017-09-25 11:21:03 -0500

DarylW gravatar image

I am trying to use the puppetlabs/apache module and attempting to define fastcgi.
Here is my fastcgi class:

class glic_apache::fastcgi (
  $fastcgihost = $glic_apache::params::fastcgihost,
  ) inherits glic_apache::params {
  #required per guardian standard
  apache::fastcgi::server { 'php':
    host       => $fastcgihost,
    timeout    => 15,
    flush      => false,
    faux_path  => '/var/www/php.fcgi',
    fcgi_alias => '/php.fcgi',
    file_type  => 'application/x-httpd-php',
  }
}

My issue is that I keep getting the following error:

Error: Execution of '/bin/yum -d 0 -e 0 -y install mod_fastcgi' returned 1: Error: Nothing to do
Error: /Stage[main]/Apache::Mod::Fastcgi/Apache::Mod[fastcgi]/Package[mod_fastcgi]/ensure: change from purged to present failed: Execution of '/bin/yum -d 0 -e 0 -y install mod_fastcgi' returned 1: Error: Nothing to do

I'm not declaring mod_fastcgi as a package and I can't find where in the apache module this would be happening either.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-09-27 21:11:38 -0500

ramindk gravatar image

updated 2017-09-28 12:50:07 -0500

apache::fastcgi::server includes apache::mod::fastcgi which tries to install mod_fastcgi. You're probably running something Redhat 7 based which require mod_fcgid. Module is out of date here. I'd modify it to include apache::mod::fcgid rather than fastcgi to get around it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-09-25 09:38:57 -0500

Seen: 88 times

Last updated: Sep 28