Getting following error when trying to run puppet agent on windows node for first time using "puppet agent -t " command

asked 2017-10-13 01:18:36 -0600

updated 2017-10-14 07:09:02 -0600

**Error:** Failed to apply catalog: Parameter creates failed on Exec[create repo_dir]: creates must be a fully qualified path at /opt/puppetlabs/puppet/modules/pe_repo/manifests/init.pp:44

edit retag flag offensive close merge delete

Comments

1

Open the mentioned file `/opt/puppetlabs/puppet/modules/pe_repo/manifests/init.pp`, look at line `44` and adjust the the `creates` attribute. In the UNIX world it has to start with a forward slash. In the Windoze world I guess it starts with a drive name e.g. `C:\`.

Kai Burghardt gravatar imageKai Burghardt ( 2017-10-14 07:13:22 -0600 )edit