Error: Could not retrieve catalog from remote server: Error 400 on Server: Unsupported 2012 R2 at /etc/puppet/modufles/WinVMtools/manifests/install.pp

asked 2017-10-13 01:34:41 -0500

Error: Could not retrieve catalog from remote server: Error 400 on Server: Unsupported 2012 R2 at /etc/puppet/modufles/WinVMtools/manifests/install.pp:27 on node hostname@dmain.com Warning: not using cache on failed catalog Error: Could not retrieve catalog: Skipping run Below is my install.pp which is getting executed. All other modules are running fine. Issue is only with the windows servers after patching is done. Before patching (I mean new server) when built there is no issue. class win-vmtools::install { $choice = 'present' $curl = 'C:/Windows/curl/curl.exe' $url = 'XXXXXXXX/dump/infra-pkg/windows/2012R2/vmtools/10.0.9/setup.exe' case $::operatingsystemmajrelease { 6: { file { 'C:/vpcinstall/vmtools': ensure => directory, }-> exec { 'extractvmtools': command => "$curl $url -o C:/vpcinstall/vmtools/setup.exe", creates => 'C:/vpcinstall/vmtools/setup.exe' }-> package { 'VMware Tools': ensure => $choice, source => 'C:/vpcinstall/vmtools/setup.exe', installoptions => [ '/s', '/v', '/qn', 'REBOOT=R', 'ADDLOCAL=ALL', 'REMOVE=Hgfs' ], uninstall_options => [ '/s', '/v', '/qn', 'REBOOT=R', 'ADDLOCAL=ALL', 'REMOVE=Hgfs' ], }-> service { 'VMTools': ensure => 'running', enable => true, } } default: { fail("UnSupported ${::operatingsystemmajrelease}") } } } Could anyone please help and let me know if u need more information?

edit retag flag offensive close merge delete