Ask Your Question
0

Error 500 on SERVER : /scripts/config_version.sh" (in directory "."): error=13, Permission denied on node

asked 2017-10-16 14:12:55 -0500

ramkrishnayadav gravatar image

updated 2017-10-16 21:31:12 -0500

Red Cricket gravatar image

Puppet Enterprise is running on the rhel amis . Puppet enterprise version is 2017 2.2 The node is running on amazon amis. Node has docker containers. There is a hiera classification involved which is working fine.

But when i run the puppet agent on the node. I see this error --

Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Warning: Facter: Could not process routing table entry: Expected a destination followed by key/value pairs, got '172.17.0.0/16 dev docker0  proto kernel  scope link  src 172.17.0.1 linkdown'
Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Exception while executing '/etc/puppetlabs/code/environments/<env>/scripts/config_version.sh': Cannot run program 
"/etc/puppetlabs/code/environments/<env>/scripts/config_version.sh" (in directory "."): error=13, Permission denied on node <hostname>
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

Can some one please guide here what is this error=13 permission denied.

edit retag flag offensive close merge delete

Comments

1

Why are you have "<env>" in the path "/etc/puppetlabs/code/environments/<env>/scripts/config_version.sh"?

Red Cricket gravatar imageRed Cricket ( 2017-10-16 21:35:03 -0500 )edit

I think I ran into the same problem with some facts parsing values/devices when I had docker installed on rhel amis.. You have to figure out which fact is having the problem, and there are ways you can run facts inside of irb and debug the specific problem. In that case, double check if ...

DarylW gravatar imageDarylW ( 2017-10-17 08:18:44 -0500 )edit
1

the config_version.sh script mentioned above, check to make sure it is executable

DarylW gravatar imageDarylW ( 2017-10-17 08:19:08 -0500 )edit

I'm getting a similar error, but mine has the correct environment listed. My issue is that everything in the scripts directory is losing execute permissions when code manager syncs it from the repo. However, I can't figure out why.

rleviseur gravatar imagerleviseur ( 2018-01-11 08:04:42 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-01-11 10:24:24 -0500

In your control repo, run: git ls-tree -r HEAD

You'll get something similar to: 100755 blob 8dd8086b633af9203a74fa108f6f3f3b427a84e4 scripts/config_version.sh

Originally, mine had 100644 at the beginning for all of the files in the scripts directory. Chmod those to add execute, commit, and push. They should then show up as 100755. So far this seems to be working for mine...for now. Give it a shot for yours.

edit flag offensive delete link more
0

answered 2017-10-24 10:35:22 -0500

annihil8ted gravatar image

Make sure the permission and owner are correct for the file and the path it resides on.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-16 14:12:55 -0500

Seen: 306 times

Last updated: Jan 11