Could not find a suitable provider

asked 2017-10-16 14:36:48 -0600

Hi, We are using the puppetlabs-aws module to manage AWS resources, in our open source puppet installation. out of no where we started getting this errors

Failed to load library 'aws-sdk' for feature 'aws' Debug: Puppet::Type::Ec2_securitygroup::ProviderV2: feature aws is missing

and then obviously

: Error: Could not find a suitable provider for ec2securitygroup Error: Could not find a suitable provider for s3bucket Error: Could not find a suitable provider for ec2instance Error: Could not find a suitable provider for ec2elastic_ip

I don't know much about ruby or ruby gems, but when I run this command line:

sudo /opt/puppetlabs/puppet/bin/gem list | grep aws-sdk

I get :

aws-sdk-core (3.6.0)

But I don't know what's the path that puppet look for this library in. **

What I tried already :

** Re-installing the aws-sdk-core library

Other information:

  • Ruby version : ruby 2.1.9p490 (2016-03-30 revision 54437) [x86_64-linux]
  • Puppet version : '4.8.2'
edit retag flag offensive close merge delete