Why can't run puppet module build?

asked 2017-10-18 04:18:41 -0600

swepps gravatar image

Hello,

I want to run "puppet module build <module name="">" and after I get next message: [LIN.FAKTORING.NET] [root@lisatellite1p swepps-sssd]$ puppet module build --debug /etc/puppet/modules/swepps-sssd Debug: Runtime environment: puppet</module>version=3.8.6, rubyversion=2.0.0, runmode=user, defaultencoding=UTF-8 Error: Could not parse JSON /etc/puppet/modules/swepps-sssd/metadata.json Error: Try 'puppet help module build' for usage

metadata.json: { "name": "swepps-sssd", "version": "0.1.0", "author": "swepps", "summary": "Manage SSSD config file", "license": "Apache 2.0", "source": "https://github.com/swepps1/puppet-module-sssd.git", "projectpage": "https://github.com/swepps1/puppet-module-sssd", "issuesurl": "https://github.com/swepps1/puppet-module-sssd/issues", "tags": ["things", "stuff"], "dependencies": [ {"name": "puppetlabs/stdlib", "version_requirement": ">= 4.20.0 <5.0.0" } ] "operatingsystem_support": [ { "operatingsystem": "CentOS", "operatingsystemrelease": [ "7" ] }, { "operatingsystem": "OracleLinux", "operatingsystemrelease": [ "7" ] }, { "operatingsystem": "RedHat", "operatingsystemrelease": [ "7" ] }, { "operatingsystem": "Scientific", "operatingsystemrelease": [ "7" ] } ], "requirements": [ { "name": "puppet", "version_requirement": ">= 3.8.6 < 6.0.0" } ], "description": "Manage SSSD config file", }

What is the problem?

Laci

edit retag flag offensive close merge delete