How to stop automatic puppet runs?

asked 2017-10-18 13:57:33 -0600

annihil8ted gravatar image

updated 2017-10-20 10:18:37 -0600

How do I stop automatic puppet runs which seem to be happening in less than the standard 30 minute window? I would like to be able to disable automatic puppet run on my nodes from the master with the option of being able to still initiate manual puppet runs from each node.

I've already enable daemonize to be false in the puppet.conf on my master but I'm still getting puppet runs on the node.

I've now tried chkconfig puppet off, puppet agent --disable, and service puppet off. I'm still getting puppet runs.

edit retag flag offensive close merge delete

Comments

1

Are you sure, there's absolutely nothing running: `ps aux | grep -i '[p]uppet'` Maybe it's induced externally: Do you have some orchestration set up? If you're still lost: Put `ps ${PPID} >> /tmp/pp` into /usr/local/bin/puppet, (_maybe_) you'll see what's calling it.

Kai Burghardt gravatar imageKai Burghardt ( 2017-10-20 11:24:50 -0600 )edit

have you checked crontab ?

raja gravatar imageraja ( 2017-10-21 12:49:40 -0600 )edit

Yeah I check crontab and I don't have orchestration. Puppet still runs somehow.

annihil8ted gravatar imageannihil8ted ( 2017-11-14 12:25:25 -0600 )edit

You overwrote the script, to see its parent process ID?

Kai Burghardt gravatar imageKai Burghardt ( 2017-11-15 04:58:48 -0600 )edit