Ask Your Question
0

Error running puppet on <node> is not connected to the PCP broker X

asked 2017-10-27 04:36:47 -0600

rssh22 gravatar image

I'm trying to run an application but I'm getting an error due to PCP broker connection

/opt/puppetlabs/client-tools/bin/puppet-job run --application "Myapp[myapp1]"
Starting deployment ...

+-------------------+---------------+
| Job ID            | 42            |
| Environment       | production    |
| Target            | Myapp[myapp1] |
| Concurrency Limit | None          |
| Nodes             | 2             |
+-------------------+---------------+

Application instances: 1
  - Myapp[myapp1]

Node run order (nodes in level 0 run before their dependent nodes in level 1, etc.):
0 -----------------------------------------------------------------------
jeer04-mw-pub-t01-n0
    Myapp[myapp1] - Myapp::Comp1[myapp1-jeer04-mw-pub-t01-n0]
    Myapp[myapp1] - Myapp::Comp2[myapp1-jeer04-mw-pub-t01-n0]
jeer04-mw-pub-t01-n1
    Myapp[myapp1] - Myapp::Comp1[myapp1-jeer04-mw-pub-t01-n1]

New job id created: 42
Started puppet run on jeer04-mw-pub-t01-n1 ...
Started puppet run on jeer04-mw-pub-t01-n0 ...
Error running puppet on jeer04-mw-pub-t01-n1: jeer04-mw-pub-t01-n1 is not connected to the PCP broker
    Affected apps: Myapp[myapp1]
Error running puppet on jeer04-mw-pub-t01-n0: jeer04-mw-pub-t01-n0 is not connected to the PCP broker
    Affected apps: Myapp[myapp1]

Job failed. 2 runs failed, 0 runs skipped, 0 runs succeeded.

The pxp-agent on both nodes seems to be running and connected to the broker according to their logs in /var/log/puppetlabs/pxp-agent/pxp-agent.log:

2017-10-27 11:27:41.501475 INFO  puppetlabs.pxp_agent.main:202 - pxp-agent configuration has been validated
2017-10-27 11:27:41.507821 INFO  puppetlabs.pxp_agent.util.daemonize:257 - Daemonization completed; pxp-agent PID=1723, PID lock file in '/var/run/puppetlabs/pxp-agent.pid'
2017-10-27 11:27:41.508072 INFO  puppetlabs.pxp_agent.agent:29 - Connecting using PCP v2
2017-10-27 11:27:41.508982 INFO  puppetlabs.cpp_pcp_client.client_metadata:125 - Retrieved common name from the certificate and determined the client URI: pcp://jeer04-mw-pub-t01-n0.msc.es/agent
2017-10-27 11:27:41.510287 INFO  puppetlabs.pxp_agent.request_processor:767 - Loading external modules configuration from /etc/puppetlabs/pxp-agent/modules
2017-10-27 11:27:41.510719 INFO  puppetlabs.pxp_agent.request_processor:818 - Loading external modules from /opt/puppetlabs/pxp-agent/modules
2017-10-27 11:27:43.603431 INFO  puppetlabs.pxp_agent.results_storage:221 - About to purge the results directories from '/opt/puppetlabs/pxp-agent/spool'; TTL = 14d
2017-10-27 11:27:43.603753 INFO  puppetlabs.pxp_agent.results_storage:270 - Removed 0 directories from '/opt/puppetlabs/pxp-agent/spool'
2017-10-27 11:27:43.604268 INFO  puppetlabs.pxp_agent.request_processor:908 - Starting the task for purging the spool directory every 24192 minutes; thread id 2
2017-10-27 11:27:43.605981 INFO  puppetlabs.cpp_pcp_client.connection:402 - Establishing the WebSocket connection with 'wss://vm-lab-linux-1.msc.es:8142/pcp2/agent' with a timeout of 5000 ms
2017-10-27 11:27:43.755791 INFO  puppetlabs.cpp_pcp_client.connection:609 - Successfully established a WebSocket connection with the PCP broker at wss://vm-lab-linux-1.msc.es:8142/pcp2/agent
2017-10-27 11:27:43.756011 INFO  puppetlabs.cpp_pcp_client.connector:213 - Starting the monitor task

I have no clue about why I am getting this error. Any help would be useful.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-11-06 09:45:38 -0600

rssh22 gravatar image

Node names in application instance declaration must be fully qualified. <node>.<domain_name>

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-27 04:36:47 -0600

Seen: 54 times

Last updated: Nov 06