Ask Your Question
0

Fully Qualified Domain Names come up as hostname.lan all the time?

asked 2017-10-31 09:44:25 -0600

leeand00 gravatar image

Now this could be more of an issue with my router / dnsmasq configuration, but...

I edited my /etc/hosts file on my Puppet agent host like so:

127.0.1.1 bareOSdirector.lan bareOSdirector
#192.168.1.12 bareOSdirector.leerdomain.lan bareOSdirector

but when I set it to

#127.0.1.1 bareOSdirector.lan bareOSdirector
192.168.1.12 bareOSdirector.leerdomain.lan bareOSdirector

The puppet master couldn't find it...and the changes were not applied.

I've also got my records for the ip's of the puppet master and the bareosdirector defined as follows in my dnsmasq.conf:

address=/bareosdirector.leerdomain.lan/192.168.1.12                             
ptr-record=bareosdirector.leerdomain.lan,192.168.1.12                           
address=/puppetmaster.leerdomain.lan/192.168.1.60                               
ptr-record=puppetmaster.leerdomain.lan,192.168.1.60

(I suppose I should have set the puppetmaster to just puppet, so it finds it automatically)

How does puppet go about finding the fqdn of a node?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-11-02 10:47:39 -0600

Your hostname is set in your network settings... it doesn't reference your DNS server (in fact you can have multiple hostnames all resolving to the same IP). Try hostname -f to return the fqdn of your host.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-31 09:44:25 -0600

Seen: 20 times

Last updated: Oct 31