Ask Your Question
0

SSLv3 Alert Handshake Failure

asked 2013-09-23 16:31:02 -0500

Ben McClure gravatar image

I am now receiving the following error message when I try to connect a new node to my puppetmaster:

Error: Could not request certificate: SSL_connect returned=1 errno=0 state=unknown state: sslv3 alert handshake failure

This was previously working and I am unsure what has changed. I have been troubleshooting two other issues: https://ask.puppetlabs.com/question/3159/exec-of-enc-script-always-returns-127/ https://ask.puppetlabs.com/question/3241/invalid-byte-sequence-in-us-ascii-when-automating-puppet/

Which seem to be related to a problem with the environment that the puppetmaster is running in (through Passenger with Nginx). I'm not sure if maybe that problem is preventing some ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-25 17:11:14 -0500

Ben McClure gravatar image

While I still don't know what actually caused this problem, running upgrades with apt-get resolved things. There must have been something broken or incompatible with the version of OpenSSL that was previously installed.

I'd still love it if someone could point me in the right direction so that I can run the puppet agent on nodes that haven't yet had apt-get upgrades run.

However, if you are experiencing this error and need it solved ASAP, try upgrading any SSL-related packages on your system.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-23 16:31:02 -0500

Seen: 657 times

Last updated: Sep 25 '13