Ask Your Question
0

Need to set "no_proxy" for windows agent

asked 2013-09-23 19:32:33 -0500

BT Somogyi gravatar image

I'm working on getting a windows agent setup which needs to have proxy settings for Internet access, but which needs to have the 'noproxy' set for connecting to the puppetmaster. I'm able to pass the proxy setting to the agent for its initial run via parameters (--httpproxyhost= & --httpproxyport=), but there doesn't appear to be a way of setting the "noproxy" parameter. I've tried both as a parameter to the agent (--noproxy) and by setting it in the Windows shell environment (set NOPROXY=...), neither of which appears to work ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-24 16:45:08 -0500

GregLarkin gravatar image

Unfortunately, there are some open bugs/feature requests but they have not been reviewed by Puppet Labs yet. Perhaps if you add your input on those issues, it will raise their visibility:

I don't know much about configuring proxies, but in the mean time, is it possible for your IT folks to configure the proxy to redirect puppetmaster connections back to the internal network address, instead of trying to connect to an external address?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-09-23 19:32:33 -0500

Seen: 1,100 times

Last updated: Sep 24 '13