Ask Your Question
0

Failed to generate additional resources using 'eval_generate':

asked 2017-12-06 17:14:17 -0600

tylerecouture gravatar image

updated 2017-12-07 05:40:23 -0600

stivesso gravatar image

When trying to run puppet on a client: sudo /opt/puppetlabs/bin/puppet agent -t

I'm getting these errors:

Warning: Unable to fetch my node
definition, but the agent run will
continue:

Warning: SSL_connect SYSCALL
returned=5 errno=0 state=unknown state

Info: Retrieving pluginfacts

Error:
/File[/opt/puppetlabs/puppet/cache/facts.d]:
Failed to generate additional
resources using 'eval_generate':
SSL_connect SYSCALL  returned=5
errno=0 state=unknown state Error:
/File[/opt/puppetlabs/puppet/cache/facts.d]:
Could not evaluate: Could not retrieve
file metadata for
puppet:///pluginfacts: SSL_connect 
SYSCALL returned=5 errno=0
state=unknown state Info: Retrieving
plugin

Error:
/File[/opt/puppetlabs/puppet/cache/lib]:
Failed to generate additional
resources using 'eval_generate':
SSL_connect SYSCALL  returned=5
errno=0 state=unknown state Error:
/File[/opt/puppetlabs/puppet/cache/lib]:
Could not evaluate: Could not retrieve
file metadata for puppet:///plugins:
SSL_connect  SYSCALL returned=5
errno=0 state=unknown state Error:
Could not retrieve catalog from remote
server: SSL_connect SYSCALL returned=5
errno=0 state=unknown state

Warning: Not using cache on failed
catalog

Error: Could not retrieve catalog; skipping run
Error: Could not send report: SSL_connect SYSCALL returned=5 errno=0 state=unknown state

How can I get the puppet agent running again on this client?

edit retag flag offensive close merge delete

Comments

DI’d you run puppet as a non root user first, and generate separate certain that way? I’ve done that before!

DarylW gravatar imageDarylW ( 2017-12-08 00:18:23 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-12-07 06:48:31 -0600

updated 2017-12-07 06:49:29 -0600

are you connecting to the correct puppetmaster?

what is the output of

puppet config print --section agent | grep "server = "

make sure you're pointing at the correct master..

if puppetmasters hostname/dns name has changed then on the client run:

rm -r /etc/puppetlabs/puppet/ssl/*

and on the master run:

puppet cert clean nameofclient

Then try puppet agent -t again..

edit flag offensive delete link more

Comments

`puppet config print --section agent | grep "server = "` gives me `server = puppet` which is correct. I can ping puppet. And all my other nodes have the same setting. However, the rest of the steps still worked. The `clean` revoked 5 total certificates after 2 runs, so maybe that was related!

tylerecouture gravatar imagetylerecouture ( 2017-12-07 11:13:14 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-06 17:14:17 -0600

Seen: 27 times

Last updated: Dec 07