Unhealthy vanilla opsworks deploy

asked 2017-12-22 10:07:50 -0500

geo gravatar image

I followed the starter-kit instructions for an opsworks deploy of PE. I had only one issue. When running

puppet-code deploy --all --wait --config-file .config/puppet-code.conf

The execute bit is removed from the puppet master for the file config_version.sh. This makes puppet runs have the following error:

Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Exception while executing '/etc/puppetlabs/code/environments/production/scripts/config_version.sh': Cannot run program "/etc/puppetlabs/code/environments/production/scripts/config_version.sh" (in directory "."): error=13, Permission denied on node

I temporarily fixed it by chmod 740 config_version.sh, but every puppet-code deploy resets it to 640. I resolved the issue by changing my environment.conf from

config_version = 'scripts/config_version.sh $environmentpath $environment'

to

config_version = '/bin/bash /etc/puppetlabs/code/environments/production/scripts/config_version.sh $environmentpath $environment'

But I am sure this change from out-of-box configuration should not be needed. Any suggestion or ideas as to why the execute bit was getting set incorrectly on puppet-code deploy?

edit retag flag offensive close merge delete