Ask Your Question

puppet server on centos 7 i386 arch

asked 2017-12-30 06:37:10 -0500

kakamo gravatar image

is it possible to install puppet server on centos 7 i386 arch, because i cant find a working repository for 32 bit version?

edit retag flag offensive close merge delete


Hi kakamo, Which Puppet Server version are you trying to install?

stivesso gravatar imagestivesso ( 2017-12-31 03:29:05 -0500 )edit

i tried to install the last version present in the, but i can take any other version working in 32 bits arch. because as fare as i understand, there is no EPEL 7 support for i386 arch, is it true?

kakamo gravatar imagekakamo ( 2017-12-31 04:58:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-12-31 10:12:20 -0500

I believe 64 bit support for cents stopped at version 6; there was an unofficial port to 64 bit but I don't believe supported - hence no 32 bit puppet for this..

options are to upgrade to 64 bit hardware or downgrade OS to rhel 6 - another option if you have a small environment (I assume you do as a 32 bit puppet master wouldn't be able to support a lot of clients - try running in masterless puppet mode - i.e. each client does a git clone of puppet modules and runs puppet agent locally (which does have 32 bit support)

best wishes


edit flag offensive delete link more


you say that there is a way to install puppet agent in 32 bits centos 7 ? because i can't find any epel 7 repository with puppet agent

kakamo gravatar imagekakamo ( 2018-01-01 09:09:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2017-12-30 06:35:35 -0500

Seen: 188 times

Last updated: Dec 31 '17