Puppet Install_options is not working on Windows

asked 2018-01-18 01:25:04 -0600

updated 2018-01-18 08:18:11 -0600

DarylW gravatar image

I am trying to install software using puppet with custom settings. it's not working if I want to install it in my user defined directory like shown below in manifest.

package { 'Notepad++':
ensure => 'installed',
source => 'C:\Published\npp.7.3.3.Installer.x64.exe',
install_options => [  '/S' , {  'INSTALLDIR' => 'c:\application\npp'  }  ],
}

It's not showing any compilation error. but installing package is default directory "C:/ProgramFiles/Notepad++". And I want it to install in "c:\application\npp" directory.

Can someone please help me in resolving it out?

edit retag flag offensive close merge delete