About | FAQ | Help
Ask Your Question
0

"stack level too deep" error on some nodes

asked 2018-02-09 15:45:17 -0500

Hypnoz gravatar image

updated 2018-02-09 17:03:49 -0500

On some servers running Centos 6, and software by Nuance (if that's relevant) that were working ok before, some recent code merge by a developer caused puppet to fail on all these machines, and also facter gives some error lines but is returning facts.

Here is the output of the command "puppet agent" which should just quit without output: https://pastebin.com/NvmYdycW

I reinstalled ruby, puppet, facter. Didn't work. I remove the puppet ssl cert, and ran "puppet agent --test --noop --server faketest". It didn't work. This means it's nothing with puppet master or the puppet modules, since it's not even connected to a master anymore.

The facts in facter will return ok, but facter gives an error like this each time as well.

Could not retrieve fact='architecture', resolution='<anonymous>': stack level too deep
Could not retrieve fact='os', resolution='<anonymous>': stack level too deep

The strange thing is there is still facter data for both those variables. Because facter is having an issue as well as puppet, it makes me think something higher on the system is wrong with permissions or ruby, etc. Is there something else I should try to reinstall besides all the ruby-* packages and facter? I don't know where else to look for troubleshooting.

Thanks for any suggestions

edit retag flag offensive close merge delete

Comments

Look at your operating system settings for max stack - it may be set to a low number.

Henrik Lindberg gravatar imageHenrik Lindberg ( 2018-02-12 02:59:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-02-12 13:49:54 -0500

Hypnoz gravatar image

I got an email with a very useful idea:

Henrik Lindberg commented:
Look at your operating system settings for max stack - it may be set to a low number.

This prompted me to check the system stack size using ulimit:

# ulimit -a | grep stack
stack size              (kbytes, -s) 512

This number is REALLY low. I compared it to a working system, which was set to 10240. So I tested increasing this value manually:

# ulimit -s 10240

And it seems after I did this all the facter/puppet commands that were broken above are working ok now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-09 15:45:17 -0500

Seen: 197 times

Last updated: Feb 12