Ask Your Question

Mcollective with tls: mco ping not working

asked 2018-02-15 07:37:33 -0600

I've the following mcollective setup:

  • broker host (middleware with activemq on port 61614)
  • control host (client where I  want to execute mco)
  • many nodes with mcollective:::server

Mcollective service can connect to the activemq worker:

activemq.rb:119:in `on_connected' Connected to stomp+ssl://

so far so good. I've followed the guide and the example's here

if I execute a mco ping, I get an answer from myself (the control host) all other nodes have a certificate related mismatch I guess:

debug 2018/02/15 13:29:40: activemq.rb:419:in `receive' Waiting for a message from ActiveMQ
debug 2018/02/15 13:29:40: pluginmanager.rb:83:in `[]' Returning cached plugin security_plugin with class MCollective::Security::Ssl
debug 2018/02/15 13:29:40: ssl.rb:222:in `deserialize' De-Serializing using marshal
debug 2018/02/15 13:29:40: ssl.rb:175:in `validrequest?' Validating request from 
debug 2018/02/15 13:29:40: runnerstats.rb:43:in `unvalidated' Incrementing unvalidated stat
warn 2018/02/15 13:29:40: message.rb:189:in `rescue in decode!' Failed to decode a message from '': Received an invalid signature in message
debug 2018/02/15 13:29:40: client.rb:137:in `rescue in receive' Ignoring a message for some other client : Message reqid  does not match our reqid 5a2bf6950ae357ccb59cccc

and idea here?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2018-02-15 10:15:11 -0600

looks like the mcollective servers didn't share the same keypair:

All servers share one “server” keypair. They must all have a copy of the public key and private key.

unfortunately the params.pp values of the voxpupuli example are wrong.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-02-15 07:37:33 -0600

Seen: 166 times

Last updated: Feb 15