Facing issues in puppetserver - puppet-agent configuration

asked 2018-02-20 02:22:47 -0600

saikagho gravatar image

I am trying to set up Puppet for DevOps. I have puppet server in Ubuntu 14.04 and puppet-agent in Windows 10. When I am generating certificate for the first time from puppet-agent (Windows 10) the SSL certficate is generating without any issues and even I can sign the same certificate from puppetserver (Ubuntu 14.04), however after signing when I am trying to update the status in puppet-agent (Windows 10) by "puppet agent -t" getting error as,

Error: Could not request certificate: SSL_connect returned=1 errno=0 state=error: certificate verify failed: [unable to get local issuer certificate for /CN=username-virtualbox.domain.com]

error message screenshot

Configuration files of puppetserver and puppet-agent:

puppet-agent config file

puppetserver config file

Troubleshooting steps already tried,

  1. Time zone in both the environments are in sync
  2. Deleted "ssl" folders containing the details of the ssl certificates from both the environments several times and re-tried
  3. 8140 ports are enabled on both Windows and Ubuntu Kindly suggest if anybody has any solution for this issue.
edit retag flag offensive close merge delete

Comments

check that the certname config entries match the FQDN of the servers they are one. puppet is picky about fqdn's matching the name in the certs. https://ask.puppet.com/question/23342/move-agent-to-new-master-unable-to-get-local-issuer-certificate-for-cn/

jason gravatar imagejason ( 2018-02-23 14:05:26 -0600 )edit