Unable to install puppetserver 5 on ubuntu 14.04 (no package present)

asked 2018-02-24 11:05:02 -0500

pbodnar gravatar image

I believe I followed all the installation instructions, still I can't see a way how to install the new "puppetserver" package. It is simply not visible in the Puppetlabs repository - not visible by the "apt-get" program.

Steps which I took based on information provided at https://puppet.com/docs/puppetserver/... and https://puppet.com/docs/puppet/5.4/pu...:

wget https://apt.puppetlabs.com/puppet5-release-trusty.deb
sudo dpkg -i puppet5-release-trusty.deb
sudo apt-get update
apt-get install puppetserver

The last command results in this error:

E: Unable to locate package puppetserver

As I don't understand the APT packaging internals, I am stuck now - what should I do to find out what's wrong?

Note that installing the "puppet-agent" package runs just fine, as does installing an older version of "puppetserver" from puppet-release-trusty.deb (but they cannot coexist along each other).

edit retag flag offensive close merge delete

Comments

Well, no answer so far, but it seems that at least for learning and debugging purposes, I can use the built-in WEBrick "puppet master", which is actually the same as a "puppetserver" with the difference that it cannot handle concurrent connections, if I understand the documentation properly...

pbodnar gravatar imagepbodnar ( 2018-03-31 04:40:14 -0500 )edit