Ask Your Question
0

Error: Failed to apply catalog: Parameter provider failed on Package[mysql]: Invalid package provider 'chocolatey' at /etc/puppet/modules/mysql/manifests/init. p:8

asked 2018-03-05 23:33:07 -0500

Ansi gravatar image

package {'mysql': ensure => latest, provider => 'chocolatey', install_options => ['-override', '-installArgs', '"/INSTALLDIR=""C:\Program', 'Files"""'], }

My puppet master is ubuntu 16.04 My puppet agent is windows 8.1

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-06 17:12:17 -0500

@Ansi it looks like you don't have the chocolatey module installed. You can find information about the module and how to install it on the forge.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-03-05 23:33:07 -0500

Seen: 69 times

Last updated: Mar 06