About | FAQ | Help
Ask Your Question
0

puppet facter not upgraded when agent upgraded

asked 2018-03-08 09:30:36 -0500

jason gravatar image

hello, i am running agent version

root@puppet:/opt/puppetlabs/server# puppet --version
5.3.2

but my version of facter is very out of date

root@mm02puppet01:/opt/puppetlabs/server# facter -v
2.5.1

I ran a apt-get install puppet-agent, and a apt-get install --reinstall puppet-agent but facter is not getting upgraded this host also is running puppetserver 5.1.3

how do i get my version of facter upgraded?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-12 07:42:20 -0500

b4ldr gravatar image

try running which -a facter looks like you have facter-ruby on your path before cfacter.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-03-08 09:30:36 -0500

Seen: 255 times

Last updated: Mar 12