Installed PuppetMaster, cannot find puppet.conf file in /etc

asked 2018-03-16 06:24:11 -0500

updated 2018-03-19 15:55:15 -0500

DarylW gravatar image

.

 Installed PuppetMaster, cannot find puppet.conf
--> Finished Dependency Resolution
Error: Package: 1:ruby-shadow-2.2.0-2.el7.x86_64 (puppetlabs-deps)
           Requires: libruby.so.2.0()(64bit)
Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps)
           Requires: libruby.so.2.0()(64bit)
Error: Package: puppet-3.8.7-1.el7.noarch (puppetlabs-products)
           Requires: systemd
Error: Package: ruby-augeas-0.4.1-3.el7.x86_64 (puppetlabs-deps)
           Requires: ruby(release) = 2.0.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@localhost ~]#

Kindly advise

edit retag flag offensive close merge delete

Comments

What platform are you trying to install on, CentOS 7? Have you followed the steps listed at https://puppet.com/docs/puppet/5.4/install_pre.html

DarylW gravatar imageDarylW ( 2018-03-19 15:56:35 -0500 )edit