Pe PuppetDB service failed to Start

asked 2018-03-22 05:25:05 -0600

Deepika gravatar image

I couldn't start the puppetserver and Pe puppetDB services. Can anybody help me to solve this error? I have mentioned the error below,

systemctl status pe-puppetdb.service

● pe-puppetdb.service - pe-puppetdb Service Loaded: loaded (/lib/systemd/system/pe-puppetdb.service; enabled; vendor preset: enabled) Active: activating (start) since Thu 2018-03-22 09:51:41 UTC; 49s ago Control: 25587 (bash) Tasks: 21 Memory: 390.3M CPU: 1min 31.913s CGroup: /system.slice/pe-puppetdb.service ├─25587 bash /opt/puppetlabs/server/apps/puppetdb/cli/apps/start ├─25595 /opt/puppetlabs/server/bin/java -Xmx256m -Xms256m -XX:+PrintGCDetails -XX:+PrintGCDateStamps -Xloggc:/var/log/puppetlabs/puppetdb/puppetdb_gc.log -XX └─25741 sleep 1

systemd[1]: Starting pe-puppetdb Service... puppetdb[25587]: The [database] classname setting has been retired and will be ignored. puppetdb[25587]: The [database] subprotocol setting has been retired and will be ignored. puppetdb[25587]: The [database] classname setting has been retired and will be ignored. puppetdb[25587]: The [database] subprotocol setting has been retired and will be ignored.

While running #puppet agent -t I got the error as failed to open TCP connection on port 8140

edit retag flag offensive close merge delete