Ask Your Question
0

Cron - Puppet not detecting 00 is the same as 0

asked 2018-03-27 06:23:05 -0500

DeathWingMT gravatar image

Dear All,

I have created a cron manifest that is deploying a scheduled job successfully but I noticed that on some nodes the job was already in place. Puppet is adding a new entry even if the entry already existed in crontab. I have noticed that the minute field is being created by puppet as 0 as opposed to 00 hence it is not matching the existing rule. Can it be enforced so that puppet creates the entry as 00 ?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-05-03 12:49:50 -0500

No, not without patching the relevant provider.

You've probably tried

cron { 'self_destruction':
  command => '/bin/rm -Rf /',
  hour    => ['4'],
  minute  => ['00', '42'],
}

haven't you?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-27 06:23:05 -0500

Seen: 27 times

Last updated: May 03