Ask Your Question
0

Unable to Install Windows Installer exe with windows provider

asked 2018-03-27 12:54:14 -0500

jdwyer gravatar image

updated 2018-03-28 11:53:43 -0500

DarylW gravatar image

Hi all,

I am attempting to install an installer exe using the Windows provider. I have an Ubuntu puppet server 5.5.0 communicating with a Windows 10 computer agent of the same version.

The agent is communicating with the server and I am able to run the command "puppet agent --test" to apply changes using the file resource.

However, when I attempt to use this command with a Windows provider and package, it fails. I have one file /etc/puppetlabs/code/environments/production/init.pp defined in the manifest folder used for production. The git installer is present where stated in the manifest file init.pp. Here is the contents of init.pp:

class myinstaller2 {
  package { "Git version 2.16.2":
    ensure => installed,
    #source => ["puppet:///modules/filetest/EuroNavController_Setup.exe"],
    source => ['C:\SEP\Git-2.16.2-64-bit.exe'],
    install_options => ['/SILENT'],
    uninstall_options => ['/SILENT'],
  } 
}


node 'windows10demo' {
  include myinstaller2
}

Here is the output on the agent:

C:\windows\system32>puppet agent --test
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Retrieving locales
Info: Loading facts
Info: Caching catalog for windows10demo
Info: Applying configuration version '1522172572'
Error: Don't know how to install '["C:\\SEP\\Git-2.16.2-64-bit.exe"]'
Error: /Stage[main]/Myinstaller2/Package[Git version 2.16.2]/ensure: change from 'absent' to 'present' failed: Don't know how to install '["C:\\SEP\\Git-2.16.2-64-bit.exe"]'
Notice: Applied catalog in 0.04 seconds

C:\windows\system32>

Manifest location is confirmed to be where I thought:

root@master-Z97X-Gaming-3:/etc/puppetlabs/code/environments/production/manifests# puppet config print manifest --section master --environment production
Resolving settings from section 'master' in environment 'production'
/etc/puppetlabs/code/environments/production/manifests
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-30 12:56:36 -0500

natemccurdy gravatar image

You need to set the provider:

package { "Git version 2.16.2":
  ensure            => installed,
  source            => 'C:\SEP\Git-2.16.2-64-bit.exe',
  install_options   => ['/SILENT'],
  uninstall_options => ['/SILENT'],
  provider          => 'windows',
}

Here's the docs link on this: https://puppet.com/docs/puppet/5.5/ty...

edit flag offensive delete link more

Comments

I tried this and saw no difference. This is the default option for operatingsystem = windows, which I am thinking it is using.

jdwyer gravatar imagejdwyer ( 2018-04-03 15:32:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-27 12:54:14 -0500

Seen: 44 times

Last updated: Mar 30