Ask Your Question
0

Puppetfile does not use latest commit on referenced module

asked 2018-03-29 00:25:26 -0600

Dopefish gravatar image

Hi All,

I'm currently using Puppet enterprise, and using a puppetfile to manage my custom modules.

E.g. (inside puppetfile)

mod 'foo_module', :ref => 'feature_branch', :git => '-gitlink-'

When I make a new commit to the foo_modules feature branch in the foo_module repository, the puppet master does not appear to check for new updates, and therefore don't see those updates, and therefore require the main puppet repo to be updated before it will pick up changes. This is an issue as it means for every development update I make, I need to update the puppetfile instead of it automatically updating the latest changes. For reasons I wont go into, puppet applying the modules locally is not appropriate currently.

Is there a way to force it to apply the latest commit without explicitly stating it? Or is this not possible with the current way the puppet master handles code updates?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-03-30 08:34:37 -0600

natemccurdy gravatar image

You'll need to trigger a code deployment whenever you want the Puppet master to check for updates of modules in your Puppetfile. It doesn't happen automatically.

How do you normally trigger code deployments? Are you using r10k or Code Manager?

For r10k, that's normally:

r10k deploy environment <environment_name_here> -p

And for Code Manager, that's normally:

puppet-code deploy <environment_name_here> --wait
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-29 00:25:26 -0600

Seen: 46 times

Last updated: Mar 30