About | FAQ | Help
Ask Your Question
0

Need assistance with puppet agent configuration

asked 2018-05-01 21:16:08 -0500

updated 2018-05-02 00:12:57 -0500

Mr_Sharma gravatar image

I need an explanation for the following problem:

# puppet agent -t
Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: Failed to open TCP connection to pmserver:8140 (getaddrinfo: Name or service not known)

Info: Retrieving pluginfacts

Error: /File[/opt/puppetlabs/puppet/cache/facts.d]: Failed to generate additional resources using 'eval_generate': Failed to open TCP connection to pmserver:8140 (getaddrinfo: Name or service not known)

Error: /File[/opt/puppetlabs/puppet/cache/facts.d]: Could not evaluate: Could not retrieve file metadata for puppet:///pluginfacts: Failed to open TCP connection to pmserver.dcgs.mil:8140 (getaddrinfo: Name or service not known)
Info: Retrieving plugin

Error: /File[/opt/puppetlabs/puppet/cache/lib]: Failed to generate additional resources using 'eval_generate': Failed to open TCP connection to pmserver:8140 (getaddrinfo: Name or service not known)

Error: /File[/opt/puppetlabs/puppet/cache/lib]: Could not evaluate: Could not retrieve file metadata for puppet:///plugins: Failed to open TCP connection to pmserver:8140 (getaddrinfo: Name or service not known)

Error: Could not retrieve catalog from remote server: Failed to open TCP connection to pmserver:8140 (getaddrinfo: Name or service not known)
Warning: Not using cache on failed catalog

Error: Could not retrieve catalog; skipping run
Error: Could not send report: Failed to open TCP connection to pmserver:8140 (getaddrinfo: Name or service not known)

In summary, I am having difficulty in finalizing the agent master relationship. It has been difficult to find appropriate documentation for configuring a server an agent.

Respectfully Submitted, Glenn Stafford

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-05-02 00:23:12 -0500

Mr_Sharma gravatar image

It seems your agent is not able to establish communication with master. If you are installing the agent first time:

  1. Make sure your master is up and port 8140 is in listening mode
  2. From your agent node you are able to telnet master 8140, check for DNS resolution as well.
  3. Put proper configuration in puppet.conf at agent node (links given below for reference)
  4. First time puppet agent run will put CSR (cert signing request), accept the certificate on master and done.

References:

https://puppet.com/docs/puppet/5.4/co...

https://www.slashroot.in/puppet-tutor...

edit flag offensive delete link more

Comments

And for more clarification, the "getaddrinfo: Name or service not known" error indicates that the DNS lookup failed. Make sure that the server setting on your agent refers to an FQDN that actually resolves.

binford2k gravatar imagebinford2k ( 2018-05-02 15:54:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-01 21:16:08 -0500

Seen: 31 times

Last updated: May 02