Ask Your Question

puppet agent installation fails on RHEL7.2

asked 2018-05-02 21:11:00 -0600

updated 2018-05-04 00:07:13 -0600

Mr_Sharma gravatar image

I have Puppet enterprise master 2017.3.5 and I am trying to install Puppet agent in an another RHEL instance. when I execute the below curl command from client

    curl -k https://<puppet_master>:8140/packages/current/install.bash | sudo bash
I am getting below error

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 25780  100 25780    0     0   464k      0 --:--:-- --:--:-- --:--:--  466k
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Cleaning repos: pe_repo
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos
+ yum list installed puppet-agent
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Could not contact CDS load balancer, trying others.

Could not contact any CDS load balancers:,
+ yum install -y puppet-agent-5.3.5
Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
Could not contact CDS load balancer, trying others.

This is actually a Proxy issue, If I setup the proxy in environment variable it fails to connect to https://puppetmaster:8140 with 403 error. If I disable proxy, It can connect to puppet master and fails during agent installation as yum doesn't work due to no proxy setup.

Any idea how to deal with it !

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-05-04 01:14:52 -0600

Mr_Sharma gravatar image

Hi Rajagopal,

well I don't have a fix for this issue but I can suggest you an option which can work in a no-internet environment - no need of yum. As you are using PE version you can find the agent installer on your puppet server at path: /opt/puppetlabs/server/data/packages/public/2017.3.5this is the path from where your curl will get the agent rpm and have it installed.

  • copy the rpm to your agent node, install it using rpm command
  • configure your puppet.conf file as per your master's certname
  • run agent and sign the csr on master

it will be done. If you want to bypass your issue this will help.

edit flag offensive delete link more


Thanks Sharma, this method works :-)

Rajagopal RC gravatar imageRajagopal RC ( 2018-05-06 21:37:13 -0600 )edit

Happy to hear that :)

Mr_Sharma gravatar imageMr_Sharma ( 2018-05-07 10:33:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2018-05-02 21:11:00 -0600

Seen: 91 times

Last updated: May 04