Ask Your Question
0

PuppetDB won't run on Ubuntu 16.04

asked 2018-05-07 23:46:28 -0600

salientdigital gravatar image

updated 2018-05-08 13:21:09 -0600

I've read through all the docs several times and have no clue why but PuppetDB is refusing to run. It is just stuck in a loop. It tries to start, then stops then tries to start again.

The error in the log is

2018-05-07 21:42:28,948 ERROR [p.p.c.services] Error while attempting to create connection pool
java.sql.SQLTransientConnectionException: PDBMigrationsPool - Connection is not available, request timed out after 15000ms.

Any ideas?

Also, really weird, but anytime I make a change to the config and restart puppetdb using

sudo service puppetdb restart

It just hangs there on the terminal. If I disable SSL, it works, so I guess the question is more about debugging SSL & Certs...

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-09 00:25:17 -0600

Hypnoz gravatar image

It looks like you posted this question 2 days ago and it wasn't answered. I looked at the log output you posted: https://ask.puppet.com/question/33993...

And in the middle I saw this message also:

Caused by: org.postgresql.util.PSQLException: The server requested password-based authentication, but no password was provided.

Check out my other answer about the setup steps I use for puppetdb on this post: https://ask.puppet.com/question/34022...

Go through and make sure you have the password configured correctly in the DB, and also in the config files.

Run some test commands such as these:

curl to get info:

curl -X GET http://localhost:8080/pdb/query/v4/facts --data-urlencode 'query=["=", "name", "operatingsystem"]'

Check all ports are listening on netstat

$ netstat -nlp | egrep "8080|8081|5432"

Connect to the postgresql db:

psql -h localhost -U puppetdb puppetdb

Finally, I agree it's strange that if you set to non-SSL it's working. If you want some simple SSL debug commands, maybe these will help but I'm not as familiar with debugging that.

echo | openssl s_client -connect <fqdn_of_your_puppetdb>:8081
echo | openssl s_client -connect <fqdn_of_your_puppetdb>:8081 | openssl x509 -noout -dates
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-07 23:46:28 -0600

Seen: 102 times

Last updated: May 09