Ask Your Question
0

Custom type: add a rubygem require [closed]

asked 2018-05-16 10:47:46 -0600

ffalor gravatar image

Hello,

I'm learning how to develop custom types in puppet.

I am making an unzip resource for windows that doesn't require us to install 7zip on every server.

It requires using the rubyzip gem.

My question is how do i get this gem to install before my resource is evaluated so i can require zip in the provider.

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by ffalor
close date 2018-05-16 12:39:54.387787

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-16 12:39:36 -0600

ffalor gravatar image

Figured it out. Simple as adding it into the gemfile of the module.

Thanks.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-05-16 10:47:46 -0600

Seen: 15 times

Last updated: May 16