Ask Your Question
0

Error: Failure to apply catalog: Parameter creates failed on Exec[create repo_dir]: creates must be a fully qualified path (file: /opt/puppetlabs/puppet/modules/pe_repo/manifests/init.pp, line: 61)

asked 2018-05-21 04:40:01 -0500

NewbiePuppet gravatar image

Hi,

I am trying to set up a windows puppet agent (Windows Server 2016) but after signing the cert on the master, and running a puppet run on the Windows agent, I got this error. I am unable to find the init.pp file. No file was changed during or after the installation of the agent.

Also, on the PE console, I can't run the puppet and it shows "Run Puppet has been disabled because Node Manager cannot connect to (the agent)."

I have checked the DNS and both agent and master are able to ping each other.

Please help!!

Much thanks!!

edit retag flag offensive close merge delete

Comments

Hi, Can you please run the agent in debug mode and check the logs what's happening. for second error, it seems you don't have mcollective services running on agent node and master is unable to communicate with your agent. once mcollective services are started you won't get this error.

Mr_Sharma gravatar imageMr_Sharma ( 2018-05-21 10:42:17 -0500 )edit

Hi Mr Sharma, Thanks for replying to my question. I ran the debug mode for the first problem. The error starts occurring when it is caching catalog for the agent node, saying that: Failed to load library 'cfproptylist' for feature 'cfpropertylist': cannot load such file -- cfpropertylist

NewbiePuppet gravatar imageNewbiePuppet ( 2018-05-21 18:56:17 -0500 )edit

For the second one, how can I start mcollective services? Sorry I am new to DevOps.. And thanks so much for your help!

NewbiePuppet gravatar imageNewbiePuppet ( 2018-05-21 21:38:21 -0500 )edit

well, I'm not very sure about first error. Did you install agent with non-administrator rights? Are you able to telnet 61613 on master?

Mr_Sharma gravatar imageMr_Sharma ( 2018-05-22 00:04:12 -0500 )edit

Both my master and agent cannot access the internet. And I did install agent with non-administrator rights. I used my another computer with internet access to install both master (Ubuntu 16.04) and agent (windows 10) and its working fine though.

NewbiePuppet gravatar imageNewbiePuppet ( 2018-05-22 00:54:33 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-30 23:58:35 -0500

joshc gravatar image

For some reason, your Windows agent has been classified as part of the PE infrastructure (as a compile master I think), and puppet trying to create a directory from which to serve repo files from (for other agents).. The error occurs because the creates parameter is being given an absolute POSIX path, but that is a relative path on NTFS, and relative paths are not allowed. Take a look at your classification rules for the Windows node in PE.

edit flag offensive delete link more

Comments

Hi joshc, thanks for the reply. I doubled check the Classification for the Windows node in PE, it is only classified within PE Agent and Production Environment.

NewbiePuppet gravatar imageNewbiePuppet ( 2018-05-31 19:40:47 -0500 )edit

Editing the `creates` path in init.pp, I am able to get the node receiving changes from the master. However, it have several warnings, and it shows the agent as failure in the PE.

NewbiePuppet gravatar imageNewbiePuppet ( 2018-05-31 19:42:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-05-21 04:40:01 -0500

Seen: 113 times

Last updated: May 30