Ask Your Question
0

Confused about Hiera version

asked 2018-05-21 14:34:43 -0500

jimr-piq gravatar image

upon a fresh install of puppetserver via https://yum.puppet.com/puppet5/puppet...

hiera --version says: "3.4.3"

I'm confused because I thought Hiera was version 5 now?

That's in a test environment.

In my production env, puppetserver 4.10, I also see "3.4.3" when I "hiera --version" from cli.

Do I just have to update my hiera.yaml to version 5 format and it like somehow magically starts using Hiera "5"?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-22 00:35:51 -0500

Mr_Sharma gravatar image

Hi, You don't really need to upgrade hiera package version to version 5. Hiera 5 has backend support for Hiera 3 and later so the features of Hiera 5 can be used on Hiera 3 by upgrading your heira.yaml to version 5 and following few steps which would enable layers of hiera.

A basic configuration of hiera.yaml could be

---
# Hiera 5 Global configuration file
version: 5
hierarchy: []

which will enable your existing Hiera 3.4.3 to Hiera 5 backend support. You can try testing on test environment using environment level or module level hiera settings. For reference: convert hiera3 migrate hiera

Hope this will help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-05-21 14:34:43 -0500

Seen: 54 times

Last updated: May 22