Ask Your Question
0

puppet agent on windows not doing work - newbie question

asked 2018-06-08 06:35:05 -0500

ovie gravatar image

updated 2018-06-12 03:35:24 -0500

Hey

I have this issue where i put simple file to my repo and want to deploy it to windows agent.

https://github.com/ovie91/control_rep...

i have manged to run it directly using: puppet apply site.pp

however when i have it on my puppet master it doesnt work, connection between master and agent has been established and certificate assinged.

my master is downloading files just fine, im able to see them on the server.

example run:

PS C:\Users\Administrator> Get-Service w32*

Status   Name               DisplayName
------   ----               -----------
Stopped  W32Time            Windows Time


PS C:\Users\Administrator> puppet agent --test
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Retrieving locales
Info: Caching catalog for client.toya.net.pl
Info: Applying configuration version '1528455115'
Notice: Applied catalog in 0.02 seconds
PS C:\Users\Administrator> Get-Service w32*

Status   Name               DisplayName
------   ----               -----------
Stopped  W32Time            Windows Time

accordingly to what is in repo it should start service however nothing is happening.

i'm losing my mind tried multiple options and dont have any more ideas.

Any suggestions?

Thanks -mat

edit retag flag offensive close merge delete

Comments

I'm confused, what do you mean by "my master is downloading file" ? Can you run the agent in debug mode? Does the clock on master and agent are in sync?

Mr_Sharma gravatar imageMr_Sharma ( 2018-06-12 07:38:46 -0500 )edit

"my master is downloading file" - my master is synchronized with my github. clock on both machine are in sync no errors in debug - link to debug output - https://github.com/ovie91/control_repo/blob/production/debug

ovie gravatar imageovie ( 2018-06-12 07:46:38 -0500 )edit

can you edit your main site.pp and place the code inside the node block which is specific for your node agent? It seem your agent is not able to pick up your resource.

Mr_Sharma gravatar imageMr_Sharma ( 2018-06-12 08:34:44 -0500 )edit

you mean to put it like that?## node 'name of the node' { code? }

ovie gravatar imageovie ( 2018-06-12 08:44:32 -0500 )edit

Yes, and that should be in your main manifest (site.pp) not inside any module.

Mr_Sharma gravatar imageMr_Sharma ( 2018-06-12 08:48:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-13 05:15:59 -0500

ovie gravatar image

the problem was in repo, i named folder manifest instead of manifests ................................................... im sad

edit flag offensive delete link more

Comments

cool, you found it

Mr_Sharma gravatar imageMr_Sharma ( 2018-06-13 08:40:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-06-08 06:35:05 -0500

Seen: 163 times

Last updated: Jun 13