How do you set enable_passwd_compat in nsswitch on Solaris 5.11?

asked 2018-06-14 16:32:01 -0600

defaria gravatar image

I have the following Puppet configuration:

 nsswitch { 'nsswitch':
    automount => 'nis',
    default   => 'files',
    password  => 'nis',
    group     => 'nis',
    host      => 'files dns nis',
    netgroup  => 'files nis',
}

But I need to set enable_passwd_compat and enable_group_compat. Here's what I'm trying to achieve from svccfg's point of view:

svccfg -s name-service/switch
svc:/system/name-service/switch> listprop config
config                      application
config/value_authorization  astring     solaris.smf.value.name-service.switch
config/default              astring     files
config/enable_passwd_compat boolean     true
config/host                 astring     "files dns nis"
config/netgroup             astring     "files nis"
config/automount            astring     nis
config/printer              astring     "user files"
config/enable_group_compat  boolean     true
config/password             astring     nis
config/group                astring     nis
svc:/system/name-service/switch>

I've tried adding something like "enable_passwd_compat => 'true'" but I just get a syntax error. Documentation on the web is scarce...

edit retag flag offensive close merge delete