Ask Your Question
0

Everytime an agent run takes place I get the same Notice

asked 2018-07-10 10:02:07 -0500

Jonar gravatar image

updated 2018-07-11 08:23:44 -0500

DarylW gravatar image

Every time i run a puppet agent -t I get the following message:

Notice: /Stage/Nagios::Import/Nagios_service/check_command: check_command changed 'check_nrpe!check_cpu' to 'check_nrpe!check_cpu '

looking like its adding a single space to the end of the config file entry.

Any ideas how to stop this? everything is working its just skewing the info in the dashboard.

It seems to do it for every entry for the nagios module i've got, which generates config files based on information stored in hiera. Thanks

edit retag flag offensive close merge delete

Comments

which nagios module are you using? Can you link to it on the forge?

DarylW gravatar imageDarylW ( 2018-07-11 08:24:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-11 08:59:58 -0500

Jonar gravatar image

Its not a module from the forge just one I put together. It's fairly simple, deploys plugins to clients and generates hiera data from which config files on the nagios server are dynamically generated. similar to what can be found in this blog post https://folgaizer.wordpress.com/2014/...

Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-10 10:00:43 -0500

Seen: 27 times

Last updated: Jul 11