Ask Your Question
0

Trouble with sslflags attibute in module puppetlabs-iis (v3.8.5)

asked 2018-08-21 07:36:00 -0600

spic gravatar image

updated 2018-08-27 09:01:56 -0600

Hi, i've tried what i could try (including googeling) but did not find any clue... Using the module puppetlabs-iis (v4.3.2) with my puppet server (3.8.5 on Ubuntu 16.04.5 LTS) i try to add an SSL binding to an existing web site (where the binding on port 80 was already successfully created through puppet):

iis_site {'www.monsite.ch':
      ensure  => 'started',
      physicalpath     => 'C:\inetpub\wwwroot\www.monsite.ch',
      preloadenabled => 'true',
      #enabledprotocols     => 'https',
      applicationpool  => 'www.monsite.ch',
      bindings             => [
      {
        'bindinginformation'   => '*:80:www.monsite.ch',
        'protocol'             => 'http',
      },
      {
        'bindinginformation'   => '*:443:www.monsite.ch',
        'protocol'             => 'https',
        'sslflags'             => 1,
        'certificatehash'      => '04c0bebf6FE3465a09bcb36043dc9ef42efd2',
        'certificatestorename' => 'MY',
      },
      ],
    }

But get an error :

Error: Failed to apply catalog: Parameter bindings failed on Iis_site[www.monsite.ch]: *:443:www.monsite.ch: sslflags must be an integer 0, 1, 2, or 3

To me it is declared as an integer ! (but i also tried different values, including the value inside simple ou double quotes, ...).

Did anyone already face this issue or see anything wrong with my code ?

Thanks a lot. With Regards

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-09-03 09:04:00 -0600

spic gravatar image

UP (just in case)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-21 07:36:00 -0600

Seen: 81 times

Last updated: Sep 03