Ask Your Question
0

Error when retreiving catalog Could not intern from text pson: "xE2"

asked 2018-08-28 04:25:24 -0600

CYBERBUG_JR gravatar image

Hello guys, Well evrything is in the title, some of my nodes fails to retrieve catalog and throws this error :

"Could not retrieve catalog from remote server: Could not intern from text/pson: "\xE2" on US-ASCII"

I've already tried to change locales on the remote hosts but it changes nothing..

Any Ideas ?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2018-08-28 23:59:43 -0600

joshc gravatar image

PSON is a legacy serialization format to work around the issue that JSON does not allow binary content, such as a file resources with a content parameter whose value contains binary data, such as when using the file function. Often PSON is able to roundtrip binary content, but if the byte sequence appears to be the start of a valid UTF-8 sequence, then the puppet agent will get confused when deserializing the catalog that it receives from the puppetserver. For example, note xE2 is the starting byte in hex for many valid UTF-8 characters such as the euro (which is UTF-8 encoded as E2, 82, AC). I'd try to use Puppet5, which will default to JSON serialization and avoid many of these problems. If your catalog contains binary file content, try using a remote file resource instead, e.g. source => 'puppet:///modules/<module_name>/path/to/file.

edit flag offensive delete link more

Comments

Okay ! Thanks for your explanation, we’ll try upgrading to Puppet 5. For the moment, i’ll check if one of my classes are using file « content » and then replace by source.

CYBERBUG_JR gravatar imageCYBERBUG_JR ( 2018-08-29 02:59:59 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-08-28 04:25:24 -0600

Seen: 108 times

Last updated: Aug 28