puppetlabs-apt proxy settings for apt::key

asked 2018-09-11 06:15:53 -0600

romgo gravatar image

I have some trouble with an apt::key deployment from this module : https://github.com/wazuh/ossec-puppet The code is

  apt::key { 'puppetlabs':
    id      => '9FE55537D1713CA519DFB85114B9C8DB9A1B1C65',
    source  => 'https://ossec.wazuh.com/repos/apt/conf/ossec-key.gpg.key',
    server  => 'keyserver.ubuntu.com',
    options => 'http-proxy="http://proxy.domain.local:8080"'
  }

Seems that source parameter URL is not using the proxy setting. If I configure my system with https_server variable it works. I think source code, use wget to grabe the file.

Without this I got timeout error.

From my point of view the bear minimum would be to update the documentation to reflect this behaviour.

edit retag flag offensive close merge delete