Is there a clear document outlining the backward compatibility of Puppet Enterprise and Puppet Agents?

asked 2018-10-11 18:42:53 -0500

Dennis184 gravatar image

I'm having trouble finding in the documentation a CLEAR explanation of the backward compatibility statement of Puppet Enterprise and Puppet Agents.

For example if an admin were running an Agent based on Puppet 5.5.6 and he had hosts running with older agents, like 5.3.5 or 4.5.2, is this supported?

I see vague statements that the Server must be at a version "newer" than the agents being managed, but they don't state clearly the limitations on this backward compatibility.

edit retag flag offensive close merge delete