puppet update from 4.10 to 6: mcollective broken dependency for puppet-agent

asked 2018-10-16 23:56:04 -0600

aLuViAn gravatar image

I am new to Puppet and have been hired somewhere that they use puppet opensource 4.10. They've requested a puppet server update with the agents and stuff. After a bit of searching in documentation, I came across this link which says the following :

Deprecation Note: As of Puppet agent 5.5.4, MCollective was deprecated and has been removed in Puppet agent 6.0.

Well, I removed mcollective resource from the manifest and then had a puppet run. Then we took a backup of the server (it is a CentOS 7 running as a VM) and I tried updating to puppet server 6 with the following method :

    [root@puppet ~]# yum update puppetserver
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: centos.turhost.com
 * epel: mirror.ps.kz
 * extras: ftp.linux.org.tr
 * updates: mirror.saglayici.com
Resolving Dependencies
--> Running transaction check
---> Package puppetserver.noarch 0:2.8.0-1.el7 will be updated
---> Package puppetserver.noarch 0:6.0.1-1.el7 will be an update
--> Processing Dependency: puppet-agent >= 5.5.0 for package: puppetserver-6.0.1-1.el7.noarch
--> Running transaction check
---> Package puppet-agent.x86_64 0:1.10.9-1.el7 will be updated
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-sysctl-data-2.0.1-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-service-common-3.1.3-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-nettest-common-3.0.4-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-sshkey-security-0.5.0-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-actionpolicy-auth-2.1.0-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-filemgr-common-1.1.0-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-nrpe-common-3.1.0-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-iptables-common-3.0.2-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-shell-common-0.0.2-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-puppet-common-1.11.1-1.el7.noarch
--> Processing Dependency: mcollective-common >= 2.2.1 for package: mcollective-package-common-4.4.0-1.el7.noarch
---> Package puppet-agent.x86_64 0:6.0.2-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: mcollective-iptables-common-3.0.2-1.el7.noarch (@puppetlabs-products)
           Requires: mcollective-common >= 2.2.1
           Removing: puppet-agent-1.10.9-1.el7.x86_64 (@puppetlabs-pc1)
               mcollective-common >= 3.0.0-1.el7
           Updated By: puppet-agent-6.0.2-1.el7.x86_64 (puppetlabs)
               Not found
                   ....................
 [Same as above for each and every mcollective packages...removed them to summarize]
                  ......................
     You could try using --skip-broken to work around the problem

I tried using --skip-broken but no luck. What am I missing here? I've spent the last 3 days finding out how to resolve the issue but I am stuck. Should I install Puppet 5 first, then remove mcollective and then update to 6? Or some other way? FYI, the repository information is as below, maybe the problem is here :

name=Puppet Opensource edition
baseurl=https://yum.puppet.com/puppet6/el/7/x86_64/
enabled=1
edit retag flag offensive close merge delete