Ask Your Question

Error 500 Could not find Class ::$classname

asked 2018-11-20 16:07:52 -0600

episong gravatar image

We recently started trying to make the switch from puppet 5.5 to puppet 6.0.3. Our environment runs perfectly in puppet 5.5 but when we switched to puppet 6.0.3 we started having this error:

"Error: Could not retrieve catalog from remote server: Error 500 on SERVER: Server Error: Unacceptable location. The name 'open_ports' is unacceptable in file '/etc/puppetlabs/code/environments/vipc_spring2019/modules/linux/configure/open_ports/manifests/init.pp' (file: /etc/puppetlabs/code/environments/vipc_spring2019/modules/linux/configure/open_ports/manifests/init.pp, line: 3, column: 1)"

To be clear this is the init.pp file that line reads "class open_ports {"

The way we have our environment structured is designed to help our system administrators when they are deploying puppet since every site is slightly different. To do this we have a slightly unique file structure. Inside our modules we have nested folders that contain our linux modules, Windows modules, and our libraries. With in each of these is another set of nested folders based on what it was doing. To accomplish this with puppet 5 we ran all of our manifests through a class and then added to the module path in the environment.conf. our line looks something like:

"modulepath = modules:modules/libraries:modules/common_settings:modules/linux/configure:modules/linux/files" etc

This was working until we attempted to make the switch to the new puppet opensource version. I have tried recreating modules with the new pdk tool and re working how we do our environment.conf and manifests. Thus far I have had no success. I would appreciate any ideas for how to fix this since I'm at my wits end with it. I'm thinking it has something to do with how the environment.conf is now parsed but I'm not sure.

Any help would be apreciated thank you in advance!

edit retag flag offensive close merge delete


Also we are using Centos 7 and windows 10 our master is a Centos 7 machine.

episong gravatar imageepisong ( 2018-11-20 16:11:10 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-12-21 14:00:35 -0600

episong gravatar image

After digging around various places and trying a lot of things. I found that puppet 6 doesn't accept module:modules/ as a start in the environment.conf removing the module:modules/ as the first entry and just placing all the entries in the modulepath without that leading module:modules/ that got us up and running on puppet 6.0.3.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-11-20 16:07:52 -0600

Seen: 101 times

Last updated: Dec 21