Ask Your Question

install archive

asked 2019-01-09 02:11:10 -0600

myname gravatar image

I'm having trouble installing archive into my puppet clients when I run puppet agent --test it tells Unknown resource type: 'archive', what am I doing wrong?

what I've done is on my puppet server on /etc/puppetlabs/code/environments/production/modules I add the file Puppetfile with the content

mod 'puppet-archive', '3.2.1'

then I have a manifest which puppet parser validate archive.pp gives as ok ( or at leas doesn't give any error )

archive { '/skelv5.tar.gz': ensure => present, extract => true, extract_path => '/', source => '', creates => '/skel' } and on the client I ran the command

puppet module install puppet-archive --version 3.2.1 ( I would also appreciate any pointer on how to do this on a manifest instead of having to run it)

now if I run it again it tells me puppet-archive 3.2.1 is already installed

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-01-09 23:57:07 -0600

Mr_Sharma gravatar image

Hi, I guess you need to define the dependency of your archive module inside metadata.json (next to your manifests directory). Reference Also, you can try declaring your archive module inside manifest.

include archive
archive { '/skelv5.tar.gz': 
ensure => present, 
extract => true, 
extract_path => '/', 
source => '', 
creates => '/skel' }
edit flag offensive delete link more


include archive did nothing, same error but I solved it, I had to run "puppet module install puppet-archive --version 3.2.1" on the server too instead of using Puppetfile

myname gravatar imagemyname ( 2019-01-10 02:00:30 -0600 )edit

Glad it got solved.

Mr_Sharma gravatar imageMr_Sharma ( 2019-01-10 04:14:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2019-01-09 02:11:10 -0600

Seen: 49 times

Last updated: Jan 09