scheduled_task no parameter named 'compatibility'

asked 2019-01-16 04:01:23 -0600

daniel.serrao gravatar image

Hi I'm using the scheduled_task version 1.0.0 to manage tasks on a Windows 2016 which is at https://github.com/puppetlabs/puppetl....

I'm trying to execute it using the following code:

scheduled_task { 'Execute BgInfo':
  ensure        => present,
  compatibility => 4,
  command       => 'C:/Windows/System32/cmd',
  arguments     => "/c \"C:/Program Files/SysInternals/${installer_name}\" /timer:0",
  provider      => 'taskscheduler_api2',
  enabled       => true,
  trigger       => [{
    schedule => 'logon',
    user_id  => ''
  }],
  user          => 'BUILTIN/Users',
}

As you can see, I'm using the provider taskscheduler_api2, but I get the error no parameter named 'compatibility'. I added the mod 'puppetlabs/scheduled_task', '1.0.0' in the Puppetfile and checked the module that is in the Puppetmaster to double check. I also checked the code in the scheduled_task repo and can see that the parameter compatibility exists, so I'm confused on why I'm getting this error.

Anyone knows what is the problem?

Thanks in advance.

edit retag flag offensive close merge delete