Ask Your Question
2

Puppet Enterprise - no certificate request

asked 2013-10-10 10:06:43 -0600

CalvinHartwell gravatar image

Hey all,

I'm trying to build a proof of concept using the installation and training material product by puppet.

I've got all of the roles :- master, puppetdb and puppet console running on one node. I can connect to the console web interface from other computers.

I've got the agent installed on a seperate vm. The hosts files for both systems have entries for either host.

The installation ran on both machines without any trouble, however, after installing the agent on the agent vm, no certificate request has been sent to the console web interface.

I've also ... (more)

edit retag flag offensive close merge delete

Comments

1

Was there any errors when the agent did its first puppet run? If you're not sure, can you try deleting `/etc/puppetlabs/puppet/ssl` on the agent, and trying ...(more)

Celia gravatar imageCelia ( 2013-10-10 16:26:48 -0600 )edit

Please include the output of `puppet agent --test` from either agent node.

ffrank gravatar imageffrank ( 2014-04-05 12:43:53 -0600 )edit

Have you configured the location of the puppetmaster in the puppet.conf on the agent? If nothing else, set up a host name in /etc/hosts as to where "puppetmaster" is.

robrwo gravatar imagerobrwo ( 2014-10-15 09:15:17 -0600 )edit

Check firewall ports (443, 8140) open between master and agents . Also, ensure you mentioned "server" entires in puppet.conf are correct, resolved 7 reachable .

shirish shukla gravatar imageshirish shukla ( 2015-06-11 01:40:13 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-19 10:50:10 -0600

awippler gravatar image

updated 2016-05-19 10:50:45 -0600

By default the puppet agent will try to connect to the puppetserver whose hostname is "puppet". (i.e. puppet agent -t --server=puppet).

If ping puppet succeeds, ensure the port 8140 is open on the puppetserver and the agent can communicate to the puppet on that port.

If the ports are open, you will need to regenerate the puppet agent cert. rm -rf /etc/puppetlabs/puppet/ssl && puppet agent -t

It could also be that the /etc/puppetlabs/puppet/autosign.conf file is configured on the master to autosign certs (which is why you would not see them in the console); however, if this is a new installation, it should not be set up.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-10 10:06:43 -0600

Seen: 277 times

Last updated: May 19 '16