Ask Your Question
0

how to install a razor client

asked 2013-10-11 05:14:30 -0500

srikanth gravatar image

I had executed the command

"puppet resource package name=razor-client provider=gem ensure=latest" but i get the following error

Error: Could not update: Execution of '/usr/bin/gem install --no-rdoc --no-ri name=razor-client' returned 2: ERROR: Could not find a valid gem 'name=razor-client' (>= 0) in any repository ERROR: Possible alternatives: razor-client, neuron-client, nevermore-client, neura-client, bamboo-client

Error: /Package[name=razor-client]/ensure: change from absent to latest failed: Could not update: Execution of '/usr/bin/gem install --no-rdoc --no-ri name=razor-client' returned 2: ERROR: Could not find a valid gem 'name=razor-client' (>= 0) in any repository ERROR: Possible alternatives: razor-client ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-11 07:05:56 -0500

gertvdijk gravatar image

updated 2013-10-11 07:07:05 -0500

Leave out the name= part. Try

puppet resource package razor-client provider=gem ensure=latest

As you can see from the error output, it's trying to find name=razor-client as the gem name, which should be just razor-client.

edit flag offensive delete link more
0

answered 2013-10-15 00:15:29 -0500

srikanth gravatar image

Dear Friend,

Thanks so much you correction helps me enable the razor-client.

edit flag offensive delete link more

Comments

Please don't post comments as answers. Vote up the answer that helped you and mark it as correct instead. That is how this site works - it's *not* a forum.

gertvdijk gravatar imagegertvdijk ( 2013-10-15 02:45:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-10-11 05:14:30 -0500

Seen: 209 times

Last updated: Oct 15 '13