Ask Your Question
2

Puppet enterprise upgrade to 3.1 issue

asked 2013-10-15 15:03:51 -0500

El3m3nt3 gravatar image

We have an issue with our upgrade. We just ran the upgrade to puppet ent. 3.1 on our existing puppet ent. 3.0. Since this was an upgrade and we already have a db, why would it have tried to setup the existing db and thrown ERROR messages. I am assuming these are serious ERRORs?

I couldn’t find anything online for any instructions on upgrade procedures. I have also included the upgrade log further below. Any help would be appreciated.

Setting up the database...

Configuring postgresql server...
PostgreSQL server configured.
ERROR: tablespace "pe-console" already exists
ERROR: role "console ... (more)

edit retag flag offensive close merge delete

Comments

What OS was this on, by the way?

Celia gravatar imageCelia ( 2013-10-15 17:57:12 -0500 )edit

It is on a RedHat Enterprise 5.9 OS

El3m3nt3 gravatar imageEl3m3nt3 ( 2013-10-16 08:28:45 -0500 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2013-10-15 16:31:40 -0500

I'm going to verify with Engineering, but I believe the errors you're seeing aren't really failures, so much as a misleading output. Because the installer and upgrader are now the same script, I think what you're seeing is just a side effect of merging the two. Those failures appear to be installation tasks, as opposed to upgrade steps, so them failing shouldn't be an issue. Your installation appears to be successful, are you seeing any issues with runs?

edit flag offensive delete link more

Comments

As far as the first set of errors, confirmed that's a bug, but it will not affect upgrading at all.

Celia gravatar imageCelia ( 2013-10-15 17:55:22 -0500 )edit

Celia, Thanks for the quick response. We also had the following post upgrade issues (our agents/clients are on Windows servers 2008 R2 SP1 OS).
1. The PuppetDB was not ...(more)

El3m3nt3 gravatar imageEl3m3nt3 ( 2013-10-16 11:17:34 -0500 )edit

I'm having the exact same problem. Same errors during upgrade, same problem when running 'puppet agent --test', and the events view in the console is broken. Help?

MikaelBarfred gravatar imageMikaelBarfred ( 2013-11-18 08:35:11 -0500 )edit

I just realized that puppetdb daemon simply wasn't running. I felt lucky, so I went ahead and started it, and now puppet agent and events tab works fine! :-). I ...(more)

MikaelBarfred gravatar imageMikaelBarfred ( 2013-11-18 09:11:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-15 15:03:51 -0500

Seen: 194 times

Last updated: Oct 15 '13