Ask Your Question
1

puppet module install --version '>= 1.0.0' is broken

asked 2013-10-23 07:36:31 -0500

themouette gravatar image

When running

$ puppet module install --version '>= 1.0.0' puppetlabs/concat

I've got following error:

Error: end of file reached
Error: Try 'puppet help module install' for usage

But according to this doc --version argument accepts requirements.

What am I doing wrong ?

By the way:

$ puppet --version
2.7.19
edit retag flag offensive close merge delete

Comments

It's also supported in 2.7.19 http://docs.puppetlabs.com/puppet/2.7/reference/modules_installing.html however I can't reproduce your error. Nevertheless I still can't ...(more)

golja gravatar imagegolja ( 2013-10-23 10:21:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
-1

answered 2013-10-23 15:16:37 -0500

lavaman gravatar image

Your issue is likely the space in your version. It should probably be '>=1.0.0' not '>= 1.0.0'.

edit flag offensive delete link more

Comments

I tried with and without space, neither worked.

themouette gravatar imagethemouette ( 2013-10-23 16:11:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-23 07:36:31 -0500

Seen: 67 times

Last updated: Oct 23 '13