Ask Your Question
1

How to install puppet on Ubuntu 13.10

asked 2013-10-24 01:25:32 -0600

Shakty gravatar image

Hi,

I'm new to puppet and would like to install it on my Ubuntu 13.10 Saucy. When I try to install it with apt-get puppet puppetmaster I get an error as soon as I run puppet with the following message:

Error: Could not run: Could not find init script or upstart conf file for 'unicast-local-avahi'

I tried to use the puppetlab Repository but I am not able to install it since it depends on hiera. Trying to install it with apt-get install puppet puppet-common puppetmaster puppetmaster-common (the -common seem to be needed since it can't resolve them ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-10-24 02:55:37 -0600

baurmatt gravatar image

updated 2013-10-24 02:57:15 -0600

It seems as there isn't any hiere package in the saucy repository yet.

Compare raring vs saucy

http://apt.puppetlabs.com/pool/raring/main/

http://apt.puppetlabs.com/pool/saucy/main/

Edit: A quick search in the bug tracker for hiera brought up this: http://projects.puppetlabs.com/issues/22905

So i guess they on to it.

edit flag offensive delete link more

Comments

is this true?

gobblepaint gravatar imagegobblepaint ( 2014-03-03 22:50:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-24 01:25:32 -0600

Seen: 897 times

Last updated: Oct 24 '13