PE 3.1 upgrade error [closed]

asked 2013-11-01 11:45:51 -0500

shchen gravatar image

We are upgrading from 3.0 to 3.1 and received the following error in the log rror: /bin/false returned 1 instead of one of [0] Error: /Stage[main]/Puppetdb::Server::Validatedb/Postgresql::Validatedbconnection[validate puppetdb postgres connection]/Exec[validate postgres connection for localhost/pe-puppetdb]/returns: change from notrun to 0 failed: /bin/ false returned 1 instead of one of [0] Notice: /Stage[main]/Puppetdb::Server::Databaseini/Inisetting[puppetdbsubprotocol]: Dependency Exec[validate postgres connection for localhost/pe-puppetdb] has failures: true Warning: /Stage[main]/Puppetdb::Server::Databaseini/Inisetting[puppetdbsubprotocol]: Skipping because ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by shchen
close date 2013-11-01 11:48:59.021572

Comments

I got the exact same error, and have no idea what to do about it. This question is marked as duplicate, but which other question is this considered a duplicate of?

MikaelBarfred gravatar imageMikaelBarfred ( 2013-11-18 08:26:26 -0500 )edit

Oh, never mind, I think I found the duplicate - I'm guessing it's this one: https://ask.puppetlabs.com/question/3697/puppet-enterprise-upgrade-to-31-issue/

MikaelBarfred gravatar imageMikaelBarfred ( 2013-11-18 08:30:42 -0500 )edit